ゲームの登録について

対応しているUnityのバージョン

投稿可能なUnityのバージョンは 5.4 ~ 2018.1 です。それ以外のバージョンについては動作を保証していません。

WebGLでビルドする

Unityエディター上でビルドするか、Unity Cloud Build(有料) でビルドする方法があります。

ゲームを登録する

unityroomにゲームを投稿するには、UnityでビルドされたWebGL用コンテンツとTwitterアカウントが必要です。

ライブラリについて

ツイート機能をつけたい

unityroom上のWebGLコンテンツにツイート機能を実装するためのライブラリを公開しています。

ランキング機能をつけたい

オンラインランキング機能をつけるサンプルを公開しています。

WebGLのエラーについて

アップロードしたゲームが動きません

unityroom上でWebGLをプレイした際にエラーが発生する場合は、以下の項目を確認してみてください。

  • UnityからBuildAndRunした場合はブラウザが起動して動作しますか?
  • unityroomのWebGL設定画面のUnityバージョンは正しいですか?
  • WebGLアップロード画面で拡張子は正しいですか?拡張子に注意しながらアップロードし直してみてください。

日本語が表示されません

Unityのデフォルトのフォント設定に日本語が含まれていないためです。対応策の詳細は以下のリンクから確認してください。

スマホで遊べますか?

基本的にスマホには対応しておりません。一部のブラウザで遊べますが、正式なサポートではないため予期せぬエラー等が発生する可能性があります。

unityroomに関する質問や不具合、要望はこちらへどうぞ

お問い合わせ